News API Historical Lookup Failures
Incident Report for Benzinga
Postmortem

This News API issue this morning was due to a scaling problem with Elasticsearch. As more resources were added to our cluster and a spike in CPU caused some shards in the index to become unavailable.

We met with our AWS partner support team as soon as possible to fix the routing issue manually (something we do not have access to).

Going forward we are defining additional best practices for how to handle this.

Posted Aug 25, 2023 - 10:12 EDT

Resolved
This News API issue this morning was due to a scaling problem with Elasticsearch. As more resources were added to our cluster and a spike in CPU caused some shards in the index to become unavailable.

We met with our AWS partner support team as soon as possible to fix the routing issue manually (something we do not have access to).

Going forward we are defining additional best practices for how to handle this.
Posted Aug 24, 2023 - 11:00 EDT