Sporadic 401 Unauthorized Errors
Incident Report for Benzinga
Resolved
The issue has been identified and we are deploying a fix.

Our API key Mongodb cluster node was out of memory and failover to recovery was not working properly. This was causing issues with API services reliably pulling API keys to authenticate against, producing a 401, or access denied.

All traffic was rerouted to the working servers and the non-working server was fixed.

We're changing the way our recovery process is being handled for this service.
Posted Jan 31, 2023 - 11:03 EST
Investigating
We are currently investigating this issue.
Posted Jan 31, 2023 - 10:51 EST
This incident affected: News API, Calendar API, Logos v2 API, SEC Filings API, Signals API (Unusual Options), Fundamentals v2.1 API, and Movers API.